Saturday, December 13, 2008

iNXES requires firmware 2.2

The iNXES XBOX Live Friends application in the AppStore requires the 2.2 firmware. While iPhone users are quick to upgrade their devices, some iPod Touch users have remained on earlier firmware for one reason or another. If you have not upgraded to 2.2 yet, you will have to upgrade to run iNXES.

Thank you all for your messages and...
don't pwn alone(tm)